обновление php с 5.1.6 до 5.2.17 CentOS 5 PLESK 9.5.3

Автор: | 04.01.2012

обновление php с 5.1.6 до 5.2.17 CentOS 5 PLESK 9.5.3

Oбновление php с 5.1.6 до 5.2.17 CentOS 5 PLESK 9.5.3

описанные ниже обновления не затрагивают панель Plesk

Для начала добавим репозиторий

 wget -q -O - https://www.atomicorp.com/installers/atomic | sh 

По умолчанию в репозитории устанавливается PHP 5.3 необходимо исключить эту версию из обновления
открываем конфиг репозитория

 nano /etc/yum.repos.d/atomic.repo 

В секцию [atomic] вставляем исключение

 exclude = php*5.3* 

Обновляем PHP до версии 5.2.17

 yum update php 

Также потребуется обновить модуль mcrypt

 yum update php-mcrypt 

После успешного выполнения команды проверьте версию PHP и работу (что расширения подгружаются и ни на что не ругается):

 [[email protected] ~]# php -v PHP 5.2.17 (cli) (built: Jan 2 2012 15:56:41) 
Copyright (c) 1997-2010 The PHP Group Zend Engine v2.2.0, 
Copyright (c) 1998-2010 Zend Technologies 
 [[email protected] ~]# php -m 
[PHP Modules] 
bz2 
calendar 
ctype 
curl 
date 
dbase 
exif 
filter 
ftp 
gettext 
gmp 
hash 
iconv 
json 
libxml 
mcrypt 
mysql 
openssl 
pcntl 
pcre 
readline 
Reflection 
session 
shmop 
SimpleXML 
sockets 
SPL 
standard 
tokenizer 
xml 
zip 
zlib 
[Zend Modules]

И перезапускаем веб-сервер Apache

 /etc/init.d/httpd restart